NeoLoader 0.31a Bug List

User avatar
Neo26
Site User
Posts: 331
Joined: Sun Dec 09, 2012 1:53 pm

NeoLoader 0.31a Bug List

Postby Neo26 » Thu May 09, 2013 3:13 pm

[color="#FF0000"]Know bugs that will not be fixed soon[/color]
- Can't choose Temp folder in 1st start wizard
-Xanatos Said- this is intended behavior (not a bug), we need to force the incoming directory and the temp directory to be on the same physical drive.
-I say- Make it like incoming folder and if "the same physical drive" condition is not respected promt an error when going to the next page.

- In 1st start wizard advanced options are not show, after turning off only grey out. It should be grey out and not invisible even first
-- removing the items again would be better i agree, but it would be more complicated to implement, and I believe it does not really matter if its grayed out or fully hidden. I will leave it as it is for the foreseeable future.

[HR][/HR]
Bug in the log
- "Instalation" instead "Installation" in log line that says update avaible
- Some things maybe have to be changed like connecting kademlia and not succesful message and connected neokad but not connecting message
- If you copy a log line it change color into blue

[HR][/HR]
UI Bugs
- Columm order is not auto-updated, you need to update it manually. I wish a switchable setting in options for that
- Can't select Temp directory in subfolder of Incoming one, else there will be download list bugged
- Scrolling the lists up or down with a lot of files you can see fitness bar number or progress %

[HR][/HR]
Core Bugs
- [color="#FF0000"]Sometimes neoloader.exe process is still running after close. You can also see that because after restart you will have a log message that tell you using a temporary port[/color]
- [color="#FF0000"]With 2 multitorrent can happen that there is a file with same name/hash but in 2 different folder of the 2 different torrent. NeoLoader don't share it when see same filename or same hash (it happened with a .txt). In less words we called it "duplicate files sharing bug"[/color]
- Video Player is not working
- Rare NeoKad crash --> http://board.neoloader.com/bugs/3269-neoloader-0-31-bug-list.html#post16243 (thx @enOehTsIsihT)

[HR][/HR]
- Pause/Stop loading are bugged. First of all in UI the downloaded data disappear when you stop loading (also the progressbar on the blue) and 2nd the connection are not dropped, I think you should check again both pause&stop.
- [color="#FF0000"]With normal connections number values you can't reach stable upload/downloads speeds. I think is a bug of the code because to make these working you have to put <10 connection, impossible![/color]

[HR][/HR]

[color="#FF0000"]This bug list will be upadted daily[/color]

enOehTsIsihT
Site User
Posts: 393
Joined: Mon Apr 16, 2012 2:22 pm

Postby enOehTsIsihT » Thu May 09, 2013 6:57 pm

Neoloader Couldnt start Search: Neo Kad Not Connected

User avatar
DavidXanatos
Site Admin
Posts: 769
Joined: Wed Jun 30, 2010 7:54 pm

Postby DavidXanatos » Thu May 09, 2013 7:26 pm

enOehTsIsihT wrote:Neoloader Couldnt start Search: Neo Kad Not Connected

fixed, there was a bug with the bootstrap script.
Live free or die trying!

User avatar
Neo26
Site User
Posts: 331
Joined: Sun Dec 09, 2012 1:53 pm

Postby Neo26 » Thu May 09, 2013 8:23 pm

But list updated... ;)

User avatar
Neo26
Site User
Posts: 331
Joined: Sun Dec 09, 2012 1:53 pm

Postby Neo26 » Thu May 09, 2013 8:49 pm

Updated again, sorry :(

User avatar
Neo26
Site User
Posts: 331
Joined: Sun Dec 09, 2012 1:53 pm

Postby Neo26 » Fri May 10, 2013 5:52 am

Updated bug list, marked as red high priority bug.

enOehTsIsihT
Site User
Posts: 393
Joined: Mon Apr 16, 2012 2:22 pm

Postby enOehTsIsihT » Fri May 10, 2013 7:59 am

"ed2k/eMule options :share new files automatically" has a bug.

video

clip0016.7z (1.7 MB)
https://mega.co.nz/#!F4UG3KwZ!Klp0h3LIKe8VvT-u1gabaifY4Ut63NFZKk0KpaEL6l4

enOehTsIsihT
Site User
Posts: 393
Joined: Mon Apr 16, 2012 2:22 pm

Postby enOehTsIsihT » Fri May 10, 2013 8:05 am

I have no idea why it produced
Attachments
NeoKad.7z
(14.39 KiB) Downloaded 97 times

User avatar
Neo26
Site User
Posts: 331
Joined: Sun Dec 09, 2012 1:53 pm

Postby Neo26 » Fri May 10, 2013 8:13 am

Hi enOehtsIsihT, (simply username...)

Thanks for reporting these bugs, I'll add in bug list.

enOehTsIsihT
Site User
Posts: 393
Joined: Mon Apr 16, 2012 2:22 pm

Postby enOehTsIsihT » Fri May 10, 2013 8:56 am

"Delete file" has a bug.

video

clip0018.7z (1.4 MB)
https://mega.co.nz/#!NlMUVASY!G4-dq2o87Yt4fF56cxbiNXsYubkAbA98XK6c7hB3VDs


Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 2 guests

cron
Fatal: Not able to open ./cache/data_global.php