0.51 Bugs

User avatar
Zebra
Site User
Posts: 19
Joined: Sat May 03, 2014 11:31 pm

Re: 0.51 Bugs

Postby Zebra » Fri Apr 03, 2015 11:48 pm

I know it's thread about 0.51, but after updating to 0.50 all NeoShare icons in Shared tab (Sources section) indicate that the file is not shared on NS network; while icons for all newly shared files are fine.
Attachments
icons.png
bug
icons.png (1.59 KiB) Viewed 988 times

User avatar
OwenBurnett
Site User
Posts: 55
Joined: Fri Feb 27, 2015 9:25 pm

Re: 0.51 Bugs

Postby OwenBurnett » Fri Apr 03, 2015 11:58 pm

Don't worry about the thread, since we are using github we can track the issue on it now. I think we shouldn't even open threads with bug lists anymore, anyway who doesn't have a github account can post in this section, opening a new thread for the bug or open a small list if encountered multiple defects.

The important is report the bugs, how/where its secondary ;)

---

Regarding the bug that you reported, try to rehash the files and check if the "neosharing" turns on after hashing. There was a lot bug about hashes/hashing in the 0.49 iirc, maybe that's why "old" files aren't shared while "new" seems ok.

I am not sure, anyway tomorrow D.X. will surely take a look.
I won a chess game against David Xanatos :D

User avatar
DavidXanatos
Site Admin
Posts: 769
Joined: Wed Jun 30, 2010 7:54 pm

Re: 0.51 Bugs

Postby DavidXanatos » Sat Apr 04, 2015 10:19 am

I'm affraid its a other issue, the network selection was reworked, and it sets the status for new files, i need to add a fix that it resets the status on client start such that old files are handles properly, fix in next beta

enOehTsIsihT
Site User
Posts: 393
Joined: Mon Apr 16, 2012 2:22 pm

Re: 0.51 Bugs

Postby enOehTsIsihT » Mon Apr 06, 2015 10:26 am


User avatar
DavidXanatos
Site Admin
Posts: 769
Joined: Wed Jun 30, 2010 7:54 pm

Re: 0.51 Bugs

Postby DavidXanatos » Mon Apr 06, 2015 4:51 pm

fixed in next build

tart
Site User
Posts: 6
Joined: Sat Mar 28, 2015 2:51 pm

Re: 0.51 Bugs

Postby tart » Wed Apr 08, 2015 6:22 pm

Hi

neoloader crashes on opening: https://mega.co.nz/#!s00xTLSZ!ZNvGdClPa ... _HVOgbVc-s

the installer can't repair it as it thinks it is already running (even if not run after rebooting)

Cheers

User avatar
DavidXanatos
Site Admin
Posts: 769
Joined: Wed Jun 30, 2010 7:54 pm

Re: 0.51 Bugs

Postby DavidXanatos » Wed Apr 08, 2015 9:38 pm

Hi,

is the installer reporting an error or is it just not installing any updates?
can you send me your filelist.xml from your config directory storred under
C:\Users\[your user name]\AppData\Local\Neo

if you installed neolaoder outside of program files
the config dir will be a sub dir of oyur instalation directroy.

Cheers
David X.

tart
Site User
Posts: 6
Joined: Sat Mar 28, 2015 2:51 pm

Re: 0.51 Bugs

Postby tart » Wed Apr 08, 2015 11:55 pm

Guten Tag David,

It's installed in the programs (x86) directory. When running installer to repair, and through some screens I select Create system restore (or not), Add to Start menu is already preselected then I press Upgrade - the error message is 'Please close all open neoloader windows first. If it does not help, please restart windows and try again'

yes, it's simply:

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<Variant Type="List"/>


but I guess the filelist should have more, I am sharing maybe 800 files and downloading about 10, depending on what the list represents.
Cheers
tart

User avatar
DavidXanatos
Site Admin
Posts: 769
Joined: Wed Jun 30, 2010 7:54 pm

Re: 0.51 Bugs

Postby DavidXanatos » Thu Apr 09, 2015 7:06 am

Than that the wrong file, the dump tells me it crashes when loading file list.
As a last resort you could try to uninstall neoloader fully after a clean reboot and than install it agian but than you aour incomplete downloads will be lost.

Alternatively we can make a Teamviewer session an di can take a look my self whats wrong and where the file ist gone.
when would you have time?

enOehTsIsihT
Site User
Posts: 393
Joined: Mon Apr 16, 2012 2:22 pm

Re: 0.51 Bugs

Postby enOehTsIsihT » Mon Apr 20, 2015 3:06 am

8.
Data loss bug
https://github.com/DavidXanatos/NeoLoader/issues/9

-----------------------------------------------------------------------------------------------------

9.
Neoloader can't search subfile's all hashes.
https://github.com/DavidXanatos/NeoLoader/issues/10

-----------------------------------------------------------------------------------------------------

10.
Neoloader can add wrong hash.
https://github.com/DavidXanatos/NeoLoader/issues/11


Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest

cron
Fatal: Not able to open ./cache/data_global.php